1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

USB Webcams - Can You Help?

Discussion in 'General Discussion' started by ChrisM, Oct 5, 2014.

  1. ChrisM

    ChrisM Administrator Staff Member

    I decided to start a thread with the hope of getting information from customers who have access to a webcam or two. In general, our Q7 device works best if you want to be able to use Skype or other apps that make use of a video imaging device.
    However, if the Android firmware on your model has the right (modules? drivers? not sure of correct terminology with Android devices), it is possible to use a USB webcam.
    Where I'm living right now, I've only got access to two webcams. I've tested these Chinese made, NoName or randomly branded devices on the DroidBOX models I have access to.
    I'll try and remember to include firmware details, as it is possible that (for example) a specific webcam will work with a DroidBOX iMX6 with one firmware installed, but if a different firmware is used, the webcam will no longer function.

    WebCams Tested
    A "Crown" webcam, can't find it online. 720p resolution, monitor/laptop screen style clamp
    Listed as Vimicro USB2.0 UVC PC Camera in Device Manager
    Hardware ID=USB\VID_0AC8&PID_3420&REV_0102&MI_00

    B Noname Dashcam #1
    720p, fakes 1080p if you switch to it
    Dark orange/bronze coloured circle around lens
    Listed as USB PC camera in Device Manager
    Hardware ID=USB\VID_0603&PID_8612&REV_0010&MI_00

    C Noname Dashcam #2, identified with same USB VID as B
    720p, fakes 1080p if you switch to it
    physically same as Noname Dashcam 1, but reddish tint, video recordings visually stutter, and inferior image quality
    Black/silver coloured circle around lens
    Hardware ID=USB\VID_0603&PID_8612&REV_0010&MI_00

    DroidBOX devices Tested with these webcams
    A - recognizes camera is attached, can open camera app, but no video output
    B/C - recognizes camera is attached, can't open camera app

    X7 - no label
    A - focal app can't connect to camera
    B/C - focal app can't connect to camera

    A - Camera app starts, with video output set to VGA or QVGA, an image visible but only updates every 15 seconds, with image replicated 4 times or jigsawed
    B/C - Camera app crashes out

    Q7 - has a built in webcam, couldn't find a way to switch cameras in Camera app or Skype

    M8 - I hope to be able to test this model soon.
    A -
    B/C -

    So, if anyone has a webcam they can temporarily unplug from their PC, or have some older models in a drawer somewhere, could you let us know the make and model of the webcam, and if it works in your DroidBOX device.

    Microsoft and Logitech webcams (but not all of them) seem to have the highest success rate from a few internet searches.
    If you have flashed your DroidBOX device with a newer firmware since you purchased it, could you let us know.
  2. Mat

    Mat Member

    http://api.viglink.com/api/click?fo...ay.google.com/store/apps/details?id=infiniteg... that's a long link? no idea if it works, but you guys will figure it out.

    anyways back to me... I received my new x7 with new wizard ready to be installed, most surprised with the speed and quality, thank you, however, and here's the thing. I received an E-Mail from you guys with this quote

    "we can replace your item with DroidBox X7 device. It's a nice modern device provided with a camera and mic."

    as my returning item had a camera and mic I was expecting this model to be of equal or superior functionality
    sadly it is not, as it is lacking in said camera and mic.

    I am however and yes there is another however, totally happy with this DroidBOX X7 (with new updated wizard) I am happy to keep it and enjoy it for as long as the bugs don't get it :)

    if that link above works and it works with any web cam please let me know.

    I am about the look for my old web cams and will post my result as soon as I have them

    thank you for listening to my ramblings, yours Mat
  3. ChrisM

    ChrisM Administrator Staff Member

    Cleaned link, should anyone be ultra-cautious about what they click on! https://play.google.com/store/apps/details?id=infinitegra.trial.usbcamera

    If I don't reply by tomorrow (my son's 3rd birthday today), give me a cyber-kick and I'll set up the app demo and a webcam. Interesting find, thanks. The reviews on the front page indicate people didn't have much joy, but if this app somehow includes basic drivers that most Android distros are missing, it could be useful.
  4. Mat

    Mat Member

    hi, my webcam and otg mini usb cable turned up today, went to insert mini otg cable but could not do this, on closer inspection the otg socket had some damage, bent out of shape, then noticed my ethernet cable had falling out when I moved my X7 DroidBOX, went to plug that back in and it is so loose it can fall out at anytime, it does not lock or click in? the box itself works fine but the quality is a bit of a let down, maybe if possible I could try that M8 if available you suggested in the first place.
    I'm so sorry but I an not happy with the faults of this box as it is. yours Mat.
  5. ChrisM

    ChrisM Administrator Staff Member

  6. Mat

    Mat Member

    hi, all other site state a webcam will only work on android device with an otg cable, but then again what do I know :) thanks for the intel, mat
  7. ChrisM

    ChrisM Administrator Staff Member

    That's probably because most Android devices don't have normal USB sockets :)
    Not all Android devices have OTG capabilities... some do, but require custom firmware to be flashed. Like the Amazon Kindle Fire2. Until you flash something other than Amazon's Fire OS onto it, it can't even use a mouse/keyboard... at least that was the case about a year ago.
  8. Mat

    Mat Member

    Thanks Silent, just enjoy learning new stuff, you have been a great help, keep up the excellent work. mat
  9. ChrisM

    ChrisM Administrator Staff Member

    I've tested that app, and it didn't help on the devices that previously showed no output with a webcam. It didn't help or even show anything at all on the M6, which surprised me. I also tried it on the Q7, just to see if it could work with the built in webcam, and it failed there too.
    In short, it performed less well than just using the Android default camera app, that appears in your list of applications if/when Android detects you have a camera on your system.
  10. ChrisM

    ChrisM Administrator Staff Member

    pibitvillage likes this.
  11. ChrisM

    ChrisM Administrator Staff Member

    T8 with S82 firmware (tests to be repeated on standard firmware)
    Logitech C920 - http://www.amazon.co.uk/Logitech-960-000767-C920-HD-Webcam/dp/B006A2Q81M (Link is for your convenience, I'm not guaranteeing it will work)
    Camera is expensive, but with Skype on a Windows client, true 1080 video calling (assuming your upload is at least 3-4Mbit) is possible. Other thank Skype, Windows PC webcam software uses 720.
    On Android? Not sure on resolution used (probably not better than a cheaper webcam) but the multistep auto focus thingy worked well, as did all the normal auto settings.
  12. ChrisM

    ChrisM Administrator Staff Member

    Logitech C920 tested with a DroidBOX iMXQpro (standard firmware, test date 7th July 2016)
    Appears to be working fine/reliably.
  13. Gibboman1953

    Gibboman1953 New Member

    I have a Beelink GT King Pro, using an old Logitech C920 Webcam. I'm using Zoom Cloud Meetings and Houseparty. The Webcam Video works fine on both apps, but I can't seem to get the Mic working. When using Houseparty, if I unplug the Webcam and plug it back in again the Video works with sound. This however doesn't seem to work on Zoom. Can anyone tell me if there is any software that I can load onto my Android TV Box to make the Webcam work properly?
  14. Dave C

    Dave C Administrator Staff Member

    Webcams are tricky on Android boxes. The most likely reason is that the app is not recognising the webcam properly. As far as I know there are no apps that would get this to work but you could try googling it.
  15. Gibboman1953

    Gibboman1953 New Member

    Thanks. It seems to work if I unplug it and plug it back in again once I'm actually using the App. (Houseparty or Zoom Cloud Meetings). If I leave it unplugged and open the App, it doesn't work. I'll keep trying. Thanks.
    admin likes this.

Share This Page