1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to properly flash rom

Discussion in 'BittBoy, PocketGo & PocketGo v2 Handhelds' started by Jakub, May 8, 2020.

  1. Jakub

    Jakub New Member

    Hi
    I just received my PocketGo v2 ( refreshed version from april 2020) and just to be sure I wanted to make extra SD card with system ( just in case SD card will stop working ) and have some improvements from rogue cfw
    To do so I followed 2 guides and flashed 1.0.5 from this site :
    https://github.com/Ninoh-FOX/POCKETGO2_ROGUE_CFW/releases/download/1.0.5/sd_image.bin
    To brand new 32GB microSD
    I tried to flash it using Etcher and win32 disk imagger. In both cases flashing was successful , but when turn off device, take out shipped in sd card with system , put my own sd card into TF1 slot and press power button , nothing happens. There is no light , no screen indication that something is happening.
    If I put my ear to device, I can hear initial silent beep when I press power button and then low pitch sound meaning that device is "working"
    Tried couple times, and there is nothing happening ( as if I try to turn on device without sd card )
    If i take out battery and put the original sd , put battery back , then old ( stock ) system boots without any issues.

    Is there any additional steps needed in order to flash system to my own sd card?
    Would be very thankful for any hints

    Guides I used:
    https://www.youtube.com/watch?v=t1fBR0YjJwU
    and
    https://www.youtube.com/watch?v=OhR6lehQb8g

    Also tried to flash 1.0 rogue and result was same ( black screen when turning on with SD card in TF1 slot )

    Moving further I tried then to flash using etcher 1.0.5 , then resized ext4 partition to 28GB, put into TF1, while also having blank 32Gb FAT32 sd card in TF2, press power button for 2-3 sec ...nothing happens.

    Then I moved and flashed original firmware from here https://github.com/retrogamehandheld/PocketGo2/wiki/Firmware-and-software-updates
    Used etcher, flashed, resized partition to 28GB , TF1 slot, power ...nothing - black screen no logo .

    I'm worried that shipped in card will eventually fail and I won't have any way to actually use the device if I can't create secondary card for it :/
     
  2. spfunnell

    spfunnell New Member

    I had a similar problem with an SD card I used. I then realised that you need to ensure it's a U3 card. I bought one of these and it works perfectly. https://www.amazon.co.uk/gp/product/B07FCMBLV6/ref=ppx_yo_dt_b_asin_title_o03_s00?ie=UTF8&psc=1

    The only issues I have left is that I want to extend the ext4 partition to the full SD card size and then upgrade to CFW 1.0.6. The upgrade seemed to work, but then not all of the buttons work properly.
     
  3. Jakub

    Jakub New Member

    Hi thx for reply. SD card is not an issue here.

    I contacted Dev responsible for CFW and upgraded PocketGo 2 motherboard might be actually an issue here.
    Rg350 firmware boots corectly, so I'm guessing, fix to pocketgo CFW is possible.
    More info here
    https://github.com/Ninoh-FOX/POCKETGO2_ROGUE_CFW/issues/35
     
  4. spfunnell

    spfunnell New Member

    Cool. Looks like you got the same issues that I got. Hopefully the dev will be able to fix it.
     
  5. Jakub

    Jakub New Member

    Yes.
    For now rogue cfw for RG350 works on PocketGo2 v2 ( updated one)
    Dev already have test image which needs some fine-tuning ( key mappings to be aligned from RG350 ) I provided some data on buttons and it should be available soon :)
     
  6. Jakub

    Jakub New Member

    Hi
    My PocketGo V2 (v2) is working without any issues on 1.0.8 version
    All buttons are correctly mapped. There is 1.0.9 version now, but crucial is text mentioned by dev in 1.0.8 release

    https://github.com/Ninoh-FOX/POCKETGO2_ROGUE_CFW/releases/tag/v1.0.9
    So if you have new ( new ) pocket go, you have to use sd_image_pg2v2 image for it.
     
    Last edited: Sep 21, 2020
Loading...

Share This Page