1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

T8-AML-V3s help required

Discussion in 'M8 and T8 (Both with LED clock on the front)' started by Finny, Nov 15, 2020.

  1. Finny

    Finny New Member

    Hi,

    Im hoping someone can help please.

    I have the above box, I bought it from entertainment box who I believe are no longer and/or not supporting these devices any more.

    Does anyone know if there is a way of upgrading the device, it’s currently android 5.1.1 and in order to use some apps that I pay for I need it to be more up to date.

    I tried something called OTA update which is on the device but just got an error message. I’m hoping that there might be another way or downloads out there that I can avail of.

    Really appreciate any help if anyone knows about these devices.

    Many thanks,

    Finny
     
  2. BenDroiX

    BenDroiX Administrator Staff Member

    Unfortunately there's generally no way to update boxes to newer generations of android. They're designed for one version from the ground-up.
    Your only options in this scenario are either to:
    • Use older versions of apps (via APK archiving sites)
    • Purchase a new box (most run Android 9 currently)
     
  3. Finny

    Finny New Member

    Thanks Ben appreciate your help. Is the ‘peer certificate’ error basically telling me that it can’t upgrade or could that be overcome? Entertainment box are no longer operating are they?
     
  4. Nigelar

    Nigelar Well-Known Member

    In most cases the Chipsets used on these older boxes do not support later versions of android. In some cases people have been able to flash a later version but invariably have found that it breaks something e.g. WiFi functionality.
     
Loading...

Share This Page