1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AlexELEC Thread

Discussion in 'General Discussion' started by ChrisM, Jan 9, 2018.

  1. ChrisM

    ChrisM Administrator Staff Member

    Not in any way an official DroidBOX thread. This is for the tweakers/experimenters.



    Interesting info from @Bar here regarding a LibreELEC/OpenELEC like OS for some Amlogic powered devices - AlexELEC site is in Russian, use Google Translate/your browser's autotranslate. Downloads linked to here, the (Russian) forum is here.)

    Apparently compatible/worth a shot if you have a S805 , S812 or S905X SoC (system on a chip, the main brain, desktop rough equivalent is the CPU).
    Just noticed at http://www.alexelec.in.ua/faylyi/ that S905 (no X is also listed, so worth a try)
    If your TV is small (720p specifically) you will be fine in Kodi, but may encounter issues with the Emulation side of things, see here.


    If anyone tries this out §§§, can you let us know the filename/link used at github and your exact model of DroidBOX, please?
    (If you're not sure, take a picture of the front, rear and underside and the community can confirm)


    (Reminder, I'm not staff, so DroidBOX's opinion on the project is not known.)

    DON'T TRY THIS OUT UNLESS YOU ARE 100% SURE YOU CAN ALWAYS RECOVER BACK TO THE ORIGINAL STATE/DON'T MIND A SOFT-BRICK TO OCCUR

    The video (for those not wanting to copy/paste):


    The location to grab the files, if your model name matches one in the first list: https://github.com/AlexELEC/AlexELEC-AML/releases

    Working (see warnings, don't flash if you can't afford to lose your device):
    iMXQpro v2 S905X reported as working by Bar, testing still required outside of Kodi for any potential sound issues

    Possible candidate machines for testing(again see warnings, don't flash if you can't afford to lose your device):
    T8 SE S905X (if you're happy potentially losing your warranty)
    T8-S Plus v2 S905 (if they're more than a year old (so no warranty))
    T8 Mini S905 (if they're more than a year old (so no warranty))
    T8-S Plus v1 S812 (if they're more than a year old (so no warranty))
    M5 or K5 S805
    iMX7 S805
    iMX6Q S805 (?)

    unknown:
    iMXQPro Mini (as it apparently has a S905W)

    iMXQpro v1.x different versions exist, will return to.
    iMXQpro MCE (will be same as one of the v1.x above)

    possibly not, but I don't have enough info to confirm:
    M6 S80?
    M8 (either version: clock on the front/not) S80?
    EM8 see above S80?
    M3 S80?
    MXQ S8??

    It isn't for the:
    iMX6 AM8726
    T8 S802
    M8 (version with clock on the front) S802 (?)
    S82 S802 (?)
    T8-S S802
    T95Z Plus S912 (presumably chipset too new for coders?)


    If your model isn't anywhere in this list, it probably isn't an Amlogic SoC running it (might be Rockchip or other)

    §§§ (I'm not repeating the warranty validity Bar mentioned in the original post, as you would need DroidBOX tech/returns staff to confirm if your warranty hasn't expired (some of the above are very old models))

    If you end up using the system, the coder has a Donate page here.
     
    Last edited: Jan 10, 2018
  2. ChrisM

    ChrisM Administrator Staff Member

    (Originally written as a reply to this:

    )
     
  3. ChrisM

    ChrisM Administrator Staff Member

    Well worth first reading through the YouTube comments and Github issues area for this project (here) if you encounter problems.
    A translated version of the changelog for different releases can be found here.

    Bar mentioned booting into TWRP (for our iMXQpro V2) without a flash at https://www.droidboxforums.com/threads/twrp-3-0-2-0-working-on-imxqpro-v2.11933/ and https://www.droidboxforums.com/posts/42429/ , not sure if there is a more recent version if you visit this post months in the future, but if you're happy "flashing" firmware already, booting from a card, backing up your FW to be on the safe side, then switching to AlexELEC without touching the NAND should mean you can safely test.

    Read my sig - I'm not DroidBOX staff, so if you are worried about your device, don't try this. If you have warranty left and don't want to lose it, don't try this.

    Just don't forget to post back in here with your results, especially for the
    • T8SE (S905X) though you may find no sound outside of Kodi, see here
      You'll want a file starting AlexELEC-S905.TX5_Pro.arm , same as for the iMXQpro v2 (also S905X)

    • T8-S Plus v1 (S812) (may lose DTS? If you have it at present, LibreELEC has equivalent patches here, so may get fixed)
      You'll want a file starting with AlexELEC-S812. Then either M8SPlus or MXIII_G as our model had 1Gbit ethernet

    • M5 or K5 or iMX7 (S805)
      You'll want a file starting AlexELEC-S805 and then TVIP.TX1 or TVIP.MXQ_V20 as this didn't have 512Mb RAM

    • iMX6Q (S805 (?))
      Agaubm you'll want a file starting AlexELEC-S805 and then TVIP.TX1 or TVIP.MXQ_V20 as this didn't have 512Mb RAM

    • T8-S Plus v2 and T8 Mini (both S905 see here for different S905 variations if the GitHub ones don't help)
      You'll want a file starting AlexELEC-S905. Ignore TX5_Pro and T95N (S905X and 1Gb of RAM), it will be one of the others.
    devices that remain untested.

    The iMXQpro v2 is AlexELEC-S905.TX5_Pro.arm

    Raspberry Pi and x86 (Don't know yet if only Nvidia GPUs supported, or if other drivers included) also possible, for any forum members with non-DroidBOX and non-Android hardware wanting to give it a whirl. Got some old laptops here that could do with repurposing...
    http://www.alexelec.in.ua/faylyi/

    Translation of the PC instructions (NOT FOR DROIDBOX HARDWARE!!!) here
     
    Last edited: Jan 9, 2018
  4. ChrisM

    ChrisM Administrator Staff Member

    For anyone who succeeds, if you need to connect to the device via SSH,
    • Login: root
    • Password: mcpc


    If you look at which file to download, the names can be broken down like this:
    example of a file: AlexELEC-PC-6.1-20151025-nv304.128
    AlexELEC-S912.MB2.arm-2.3.5

    AlexELEC - OS name
    S912 - processor type ( PC - for x86, RPi2 - for Raspberry Pi-2 )

    (for non Android devices, may also include an OS version, year, month and build number and version of drivers/other core sw in filename)
     
  5. Bar

    Bar New Member

    AlexELEC (2.2.2) booting from SD card (class 10 recommended) with imxq pro v2 (dual boot system)
    Code:
    https://github.com/AlexELEC/AlexELEC-AML/releases/download/2.2.2/AlexELEC-S905.X96.arm-2.2.2.img.gz
    and lastest version (2.3.5):
    Code:
    https://github.com/AlexELEC/AlexELEC-AML/releases/download/2.3.5/AlexELEC-S905.X96.arm-2.3.5.img.gz
    If you have problems booting, after writing AlexELEC-S905.X96.arm-x.x.x.img.gz to SD, rename below dtb to dtb.img and place on SD, overwriting original dtb.img file (2GB RAM)
    Code:
    https://github.com/AlexELEC/S905-trees/blob/master/S905X/gxl_p212_2g.dtb
    As soon as installed, go to Addons, check updates as there's a python update that is required to avoid dependency errors.

    so you can Triple Boot AlexELEC, reboot to droid and have the original dual boot of droid / LibreELEC (depends if you press menu on remote on reboot). if you want to reboot AlexELEC, just leave SD card in slot or use toothpic method if rebooting from droid / Libre..

    Captured video of it running ;
    Code:
    http://sendvid.com/rlvhimjk
    Update: IPVanish working with zomboided addon, temps appear stable

    [​IMG]

    [​IMG]
     
    Last edited: Jan 10, 2018
    ChrisM likes this.
  6. Bar

    Bar New Member

    LibreELEC 9.0 / Kodi 18.0 Alpha also running from SD Card.
    Also installs to internal ;)

    Verify device tree before installing to internal or you risk a brick..

    Had to run installtointernal twice via PuTTY to get rid of existing partitions but so far, so good. Runs very fast, low memory use and CPU temp appears to be lower than usual. Installing to internal WILL wipe out any DBox firmware but if you don't need droid environment?

    [​IMG]

    Release:
    Code:
    http://libreelec.adamg.co.uk/releases/LibreELEC-S905.arm-8.90.1.img.gz
    You have to put device tree on SD or system won't boot.
    Code:
    https://sx05.eu/s905/8.2/device_trees/S905X/gxl_p212_2g.dtb
    Full info here:
    Code:
    https://forum.libreelec.tv/thread/5556-howto-faq-install-community-builds-on-s905-s905d-s905w-s905x-s912-device/
    Adamg's Build:
    Code:
    https://forum.libreelec.tv/thread/10301-8-90-1-libreelec-9-0-alpha-for-s905-s912-lepotato/
    Video of it running from Cold Boot on iMXQpro:
    Code:
    http://sendvid.com/4y6bd4st


    This is as far as I need to go with this! Spent days on it! I've got LibreELEC 9.0 / Kodi 18.0 running. All I ever wanted was to have the DBox firmware and be able to update LibreELEC to latest but due to everything in system info having Droidbox all over it, it made it difficult to workout which build to install.

    This should work on any hardware with S805 / S812 / S905 / S905x SoC's, just pick the correct Builds and dtb files, but, once again, I'd reckon DroidBox want nothing to do with it and
    I'm not responsible for Bricked boxes.

    Peace!
     
  7. ChrisM

    ChrisM Administrator Staff Member

    PC version. The download link from the site's Files section was for Kodi 15.2, so updated to the latest version of AlexELEC kernel and system files from github, giving Kodi 16.1 . Dependencies not met led to issues with some video and program add-ons, but some of it worked. Switching to Lubuntu (trying to find lightweight OS+Kodi for a couple of very old, underpowered laptops).

    Still not had a chance to try it on Android yet.
     
  8. sean99

    sean99 Well-Known Member

    Installed this on a T8s Plus V1 using this file from the github link @ChrisM and @Bar posted above:- https://github.com/AlexELEC/AlexELE...6/AlexELEC-S812-TVIP.MXIII_G.arm-2.3.6.img.gz. Using an 8gb sdhc sd card formatted to fat32, as posted earlier just unzip the rar file once downloaded on your pc and use win32diskimager to get the image file onto the sd card. Use the toothpick method to install it from the recovery menu, if you are not familiar with this method I would do some research before attempting this. Am still testing this out and its running pretty good, Kodi 17.6 with a game emulator (of no interest to me) also has acestream engine ready to install to stream p2p links and thats a gamebreaker as in OE and LE it can't be installed/used. The bluetooth driver connects 1st time everytime:D and the system is pretty nifty with no lagging when closing streams or navigating around the system settings as in LE. Anyway my 1st impression is that it runs very well so any other tweakers give it a go (only at your own risk as the guys from dbx say) my box is well out of warranty but have all necessary f/w files to recover the system if any problems occurred. Biggest problem was changing language from russian to english, but just watching the video in the link shows how to change it easily enough. Ps. the stock remote does not work and have not tried to swap any files to get it to work as my Rii wireless keyboard works fine, also my openvpn connection is not as strong as LE but will try and change a few settings to get that up to speed. nothing installs to your boxes internal memory so just removing the sd leaves your box how it was before the install, USE AT YOUR OWN RISK!!

    Edit: To enable the stock android remote goto alexelec advanced/ services/ IR remote/ ok to enable.
     
    Last edited: Mar 6, 2018
    Bar and ChrisM like this.
  9. Bar

    Bar New Member

    Nice One sean99. Been running Libreelec for 3 months now, everything stable with the "LibreELEC-S905.arm-8.2-8.2.3.1" on Droidbox iMXQpro v2. This is the last Stable version for Libreelec 8 / Kodi 17.6 as the devs are working on Libreelec 9 / Kodi 18 now.

    Download image file here:
    Code:
    https://kszaq.libreelec.tv/s905/8.2/8.2.3.1/LibreELEC-S905.arm-8.2-8.2.3.1.img.gz
    Download Device Tree for S905 here:
    Code:
    https://kszaq.libreelec.tv/s905/8.2/device_trees/S905X/gxl_p212_2g.dtb
    For anyone else wanting to try it, download both files, write the Libreelec image to SD Card with LibreELEC.USB-SD.Creator.Win32 / win32diskimager / Rufus. When image written, rename the device tree (gxl_p212_2g.dtb) you downloaded to dtb.img and copy over to SD Card, overwriting existing file.

    Boot with toothpick method.and once happy with it, you can SSH into box and run "installtointernal" command (Optional) to run from nand (no use all that internal memory doing nothing ;)). After a reboot, remove SD Card and have a lightning fast Libreelec running on your iMXQpro v2.
     
    sean99 likes this.
  10. sean99

    sean99 Well-Known Member

    @Bar I take it this same L E image can be used on the T8 mini S905 chipset? Am gonna give it a try anyway thanks pal.
     
  11. Bar

    Bar New Member

    Aye, should do. If you get any errors, try swapping device tree for another as I cannot find specs for T8 mini. If it's 1gB RAM, download gxl_p212_1g.dtb. If it's 2gB RAM, download gxl_p212_2g.dtb and so on.
     
    sean99 likes this.
  12. sean99

    sean99 Well-Known Member

    Can run the new L E update kodi 17.6 from sd card with no problems, using putty to 'installtointernal' command to finish up just solely keeps L E on the box and presumably wipes the android side off (its done that my end) is there a way to do this update to also have a working dual boot box? Have recovered it no problem...
     
    Last edited: May 3, 2018
  13. sean99

    sean99 Well-Known Member

    Update! Lol not recovered but bricked unless running L E 17.6 from sd card as reinstall of original f/w ends with errors. You win some......
     
  14. sean99

    sean99 Well-Known Member

    Would it be possible for dbx to give me access to a T8 mini image file I can use with a burning tool to try and get this box working again please, my tinkering days are overo_O
     
  15. Nigelar

    Nigelar Well-Known Member

  16. sean99

    sean99 Well-Known Member

    Thanks pal but no,have got and tried all dbxs relative f/ws. I dont have any screenshots to hand but am being told after trying to install the latest f/w available that the box is unrecoverable or as to speak. Just after using the command with putty to 'installtointernal'
     
  17. sean99

    sean99 Well-Known Member

    All sorted now after a fresh installtointernall command using putty, @Bar have you any idea how I get the ir remote to work with this tho? As the alexelec had the option in its advanced setting.
     
Loading...

Share This Page